PHP 5.4.0 or greater is required.